Openfire 3.6.4 on Ubuntu 10.04LTS

After installing Ubuntu Server 10.04LTS on to one of my VMs, I found I couldn’t install Openfire due to a missing dependency on sun-java6-jre. The Sun JRE has been removed from Ubuntu 10.04LTS, and its replacement, openjdk-6-jre isn’t quite up to scratch.
As reported elsewhere, here’s how to install sun-java6-jre:

  • Modify /etc/apt/sources.list and add deb http://archive.canonical.com/ lucid partner
  • Update the package database by running apt-get update
  • Install the Java runtime environment using apt-get install sun-java6-jre

Simples.

Leave a Reply

Your email address will not be published. Required fields are marked *